PDA

View Full Version : iSync not working :(



Gregorius
3rd December 2007, 09:27 PM
Hey all,

I have a problem with iSync... seems its not working, and many services that rely on it wont work either... it first happened about 2 months ago when i could no longer sync my ipod touch to my PC - itunes would throw that error... then i realised that Spanning Sync had stopped working too... its troubleshooter says to try restart the iSync service by Starting iSync and going into the preferences... but starting iSync just causes the icon to appear in the dock, and the menu bar to appear, but no preferences option, and can't do anything... right-clicking the dock icon and clicking "Sync devices" causes a window to pop up and say "Synchronization is not enabled on the computer. You need this turn on synchronization in iSync preferences...." This is the same error i get when i try to sync iTunes with my iPod.

I've tried various things, including reinstalling OS X over the top.. but no go. Hoping somebody can help me out with this...

thanks heaps
greg

justjack
13th March 2009, 08:57 AM
Hi All,

I've encountered a similar problem. I sync Enoturage with iCal & Address Book but out of nowhere last night, sync services started triplicating all my calendar entries... Following some search info, I turned of sync, deleted a bunch of stuff from ~/Library/System Prefs(?), reset sync services in iSync and then turned sync back on in Entourage.

When I retried in iCal, it ended up only populating some of the details and created an Entourage 2. Then when I tried to sync with iPhone in iTunes 8.1, it errored saying sync services not active.

I reset AGAIN, and from the menu bar noticed that no matter how many times I tried to turn SS off and on in iSync (including numerous reboots), I could not get SS to register as active.

Any ideas pleeeeeeeeeeeeeeeeeeeeease??? :confused:

justjack
17th March 2009, 10:03 PM
Bumping for help...

tmvictoria
15th April 2009, 02:56 PM
Wow, I had the SAME PROBLEM! i think it quintuplicated mine though...I think the problem is that so many things are synching in the background, like Mobileme, .Mac, Isynch. I turned off the synch between Entourage and Ical and manually deleted the data but am afraid to turn it back on!

kenexx
15th April 2009, 04:51 PM
I too have just had the same problem and looking at Activity Monitor SyncServices was eating all my ram. The iMac was almost unusable. I did a bit of research on the Apple forums and found the following (http://discussions.apple.com/thread.jspa?threadID=1965384&tstart=15):


"Ok, as you can't reset SyncServices in the "normal" way, you'll have to resort to the "other" way:

Although it's not advised to do so in normal circumstances, you'll need to manually delete the SyncServices folder.

Before doing so, you MUST make a backup of both your Contacts and Calendars:

In Address Book, choose Export > Address Book Archive... from the File menu.
In iCal, choose Back up iCal... from the File menu.

Then, make a backup of the SyncServices folder located at:

~/Library/Application Support/SyncServices

By backing everything up first, you don't risk losing anything.

Finally delete the aforementioned SyncServices folder and restart the Mac. This will force Mac OS X to recreate the SyncServices folder, and hopefully fix your problem."

It fixed mine instantly. I had posted about it in another thread and Clockwork kindly posted a reply with an entry to try in Terminal. I'm not all that comfortable playing with Terminal so I used the above.

I should mention that my error response wasn't exactly the same as the example above but it was close enough for me. :tongue:

Give it a go and hopefulyl it will fix your problem as well.