PDA

View Full Version : Symptoms of dead/dying HD under OS X?



Byrd
27th February 2005, 09:05 AM
Hi,

I'm trying to determine if the 20GB hard disk in my girlfriend Clamshell iBook is faulty, or if the motherboard is suspect. At present I'm having awful times installing OS X - 10.3 refuses to boot from the install CD, while 10.2.4 does, but once the the installer has finished it only boots 50% of the time.

The Disk Utility software under 10.2.4 (all I can run at present) gives confusing information under 10.2.4, nothing that really tells me the HD is rooted.

These are the errors I'm getting:
- Garbled video at startup, after the grey apple (sort of like the image has corrupted)
- Running Disk Utility's Verify Disk comes up with an error of "Keys out of order", and I cannot repair this.
- Numerous disk permission errors, even when I can't boot into OS X on a fresh install!

Has anyone had similar problems with a dead/dying hard disk under OS X? It appears to be a faulty HD, but it's hard to precisely work out what the problem is. I don't have TechTool Pro, so using the existing Apple utilities is all I've got.

JB

LCGuy
27th February 2005, 09:31 AM
Have you tried copying anything to it yet? Usually you can find out by copying something, and then watching as it complains about bad sectors.

Byrd
27th February 2005, 09:37 AM
When the Clamshell had a working install of 10.2.4, I copied a 700MB movie and it played back fine. However, it refuses to open and install some disk images. Now I'm unable to boot to OS X, so it's likely the HD getting worse.

I've always put it down to overclocking the Clamshell iBook (300 @ 366 or 400Mhz), but don't think that's it, seems the HD has always been the culprit.

LCGuy
27th February 2005, 09:40 AM
You're not going to like this, but i'd say try another HD in it. If its still messing up, then i'd say its because it's been OC'd.

Byrd
27th February 2005, 09:42 AM
I've got a spare 10GB drive from my Dual USB iBook, will do. I've become such an expert at dismantling the Clamshell it only takes about five minutes now :D

JB

LCGuy
27th February 2005, 11:54 AM
Wow, you must be good then. :P If it makes you feel any better though, i'm one of those weird people who can completely field strip a PM8100 in about 5 mins. :P

zefi
27th February 2005, 03:10 PM
This is slightly related to your issue, everyone should download SMARTreporter. It is a utility that monitors and displays the status of your hard drive, much like when you open Disk Utility and it says 'verified'. This just lets it reside in your menu bar, very useful and free.

srnm
28th February 2005, 08:32 AM
Apple's Disk Utility (>10.3?) will display the S.M.A.R.T. status of a drive if you select the drive, not the volume, from the source list. The status appears at the bottom of the screen.

Also, darwinports has smartmontools but your system needs to be fully functional before attempting to install darwinports.

My hard drive did report failure before it actually failed -- but not before I had noticed other symptoms...