PDA

View Full Version : Superdrive: Way too sensitive!



Prince_Alexander
10th October 2007, 03:12 PM
Hello all,

First time poster, here. This site was a valuable source of info in the lead up to my first mac purchase. I bought a 24" 2.4 alum iMac as soon as they were released. I guess that's a belated "thanks" from me!

So far, I love my Mac. I can't imagine going back to a PC, and find using my old Toshiba notebook a real struggle these days. The learning curve has been steep, but fairly uneventful.

My only complaint is with the superdrive. It relates specifically to importing cds into iTunes. Admittedly, I have some old, rather damaged discs. They all seem to play without difficulty in other computer drives, and various dvd players etc. in the car and house. When I attempt to import them (and we're talking about 20-odd discs here) into iTunes, the process will pause at some point. The drive makes an incredible amount of noise which clearly sounds as though it is having problems reading the disc. The only way to fix the problem is to force quit iTunes, and eject the disc. Obviously, this is irritating me to no end. I've had no problem with 90% of my collection.

Any ideas? Anyone else experience this? Could it be a faulty drive?

Any help would be great. This is the one issue that's really mucking up my mac experience!

step_andy
10th October 2007, 03:55 PM
Try saving the disc as an image on your hard drive and importing the contents from the image.

Arkhum_Eramak
10th October 2007, 03:57 PM
I second saving as an image (disk utility > newimage > CD/DVD master) or try just ripping it on your Toshiba notebook if that will do it fine. Ultimately, I've found that laptop drives, and slot-loading ones in particular, to be a little more temperamental than other types. Go into iTunes prefs and turn on the option for error-correction as well, that may help.

jubilantjeremy
10th October 2007, 03:57 PM
(Hey, it's the fresh prince..)

Welcome, anyway :)

I don't have any direct advice or suggestion about the superdrive; the one in my macbook imported all my CDs fine. It does occasionally go 'spin crazy' though, but that happened more frequently on my old ibook with combo drive.

I do have problems burning cheap DVD-Rs on my macbook which my PC's old LG burner doesn't have an issue with.

With regard to importing the CDs - if it's only a few, you may as well just rip them on another computer, then locate the files in itunes and click 'show in finder'. Copy these files to a USB drive or something, then just drag them into your own itunes.

Hope it works out -

Jeremy

Mutters
10th October 2007, 04:08 PM
P.A.

I suspect it could also be related to those DRM'd CD's that were getting around.
I had one play havoc with my drive.
The solution was to record it directly from a stand alone CD player.
Does this relate?

mutters

Prince_Alexander
10th October 2007, 04:21 PM
I'll give the image process a go, and let you know! I hadn't even considered doing that!

I hear you on the toshiba idea as well...but it just adds another step I'd like to avoid now, and in the future! So, as a last resort, I might need to do it this way :(


I suspect it could also be related to those DRM'd CD's that were getting around.

I think most of them pre-date that, but I'm not sure!

Lets hope it doesn't come to that!

Thanks all! I'll keep you posted!

jubilantjeremy
10th October 2007, 04:22 PM
I second saving as an image (disk utility > newimage > CD/DVD master) or try just ripping it on your Toshiba notebook if that will do it fine. Ultimately, I've found that laptop drives, and slot-loading ones in particular, to be a little more temperamental than other types. Go into iTunes prefs and turn on the option for error-correction as well, that may help.

When I try to do this, the option for Disk Image From (Select a Device) is greyed out... what gives..?

Jeremy

Prince_Alexander
10th October 2007, 04:44 PM
hmm...it didn't work. The image is created, and it mounts ok, but there's nothing in it!

I even tried dragging it, and importing it, into itunes, and nothing happened. Ideas?

decryption
10th October 2007, 04:47 PM
In the iTunes preferences, go to "Advanced", then click the "Importing" tab. Tick "Use error correction when importing CDs".

It will go slower, but should result in a better quality rip.

cosmichobo
10th October 2007, 05:00 PM
Hate to state the obvious...

But have you tried buying some lense cleaner (spray) from Sunglass Hut/etc and give the CDs a good clean with a microfibre cloth...

Might help the drive to read them.

OR

Link your Laptop up to the Mac, and then use the Laptop to read the CDs and move the songs over using ethernet...