PDA

View Full Version : iWeb '08 Help Strange Fonts



Rodney9
12th September 2007, 01:58 PM
Hello,

I made a new web site with iWeb '08, it looks ok in iWeb but after uploading to my isp the pages have a strange font ( ) all over the pages and where I wrote G'Day I get ( G’Day ).

Any Idea what's going on and how to fix it ?

Rodney

Rodney9
12th September 2007, 02:13 PM
I found the answer , how crazy, why is it always ?

http://homepage.mac.com/thgewecke/iwebchars.html

Fixing Strange Characters on iWeb Pages

Diagnosis

If you are seeing question marks on your pages, go to the section FTP Settings below.

If you are seeing characters like , ’ or other strange Latin letters where spaces and punctuation should be, go to the section on Server Settings below.

FTP Settings

If you are using an FTP program to put iWeb pages onto a server, you can run into problems caused by that program corrupting characters. This will most likely result in question marks on your page when viewed with your browser Text Encoding set to UTF-8. In Fetch, go to Preferences > Misc and set the preferred encoding to UTF-8 (v. 5) or uncheck any box which says "Translate ISO Characters" (v. 4). Setting Preferences > Upload to Raw Data rather than Automatic may also do the trick. In CyberDuck, try setting View > Encoding to UTF-8 and perhaps Transfer Mode to Binary. For InterArchy, you need to uncheck Preferences > Translation > ISO-8859-1 and maybe set Transfer Mode to binary. Other FTP programs may require similar adjustments.

Server Settings

If a page you create in iWeb and publish to a server other than .Mac contains strange unwanted characters, try setting View > Text Encoding in your browser to UTF-8. If this makes it appear correctly, it means your server is probably forcing browsers to interpret the page as being in Latin-1 encoding. iWeb pages are in UTF-8 encoding so that they can accomodate all languages, not just English and those of W. Europe, and there is no practical way to change this.

Web servers should not be set up this way: They should let the code inside the page determine what encoding the browser is set to. If the people running the server will not change it, you have to set up a separate .htaccess file for your server space to set the encoding right.

This is just an ordinary plain text file named .htaccess with the text "AddDefaultCharset UTF-8" or "AddCharset UTF-8 .html" or possibly "AddDefaultCharset Off" (no quotes). This file should be located at the top level of your space on the server, but you may also need to put it inside the public_html folder if there is one. Files with a . before the name are often invisible, so you may need to select "show hidden files" or a similar setting to see them.

If your server uses XSHTTPD, you should edit the ".charset" file to contain the line: UTF-8.

A good program for making/editing such files is TextWrangler. Just compose the text and use File > Save to FTP Server.

If the only problem on your pages occurs where you should have quotation marks, apostrophe's, and dashes, then a quick fix may be to go to iWeb/Preferences and uncheck the box for "Use smart quotes." It would still be better to fix the server settings, however, since these can only cause you problems in the longer run.

If you cannot have your own .htaccess file (some servers do not allow this), there a couple of possible other solutions: You could open your .html pages with TextEdit (set to Western Latin ISO encoding) and manually edit them before uploading to remove offending characters. You could also open all your pages with TextEdit while set to UTF-8 encoding, then do Save As choosing the encoding Western Latin ISO. Both of these tricks need to be redone every time you republish your site.

For further info see:

w3org on htaccess

w3org on headers and charset

Rodney9
12th September 2007, 02:44 PM
I did not find the answer,
None of the above works , I tried - AddDefaultCharset UTF-8
AddCharset UTF-8 .html
AddDefaultCharset Off

What else can I do ?

Rodney9
12th September 2007, 04:45 PM
Anyone using iWeb 08 with Internode ?

Rodney9
12th September 2007, 07:54 PM
Anyone ?

vivid2
12th September 2007, 08:19 PM
What you can do is to replace the recalcitrant characters with standard HTML entities.

What is the encoding on your web page/s? Perhaps providing the link here would help.

Look at this link for entities:
http://www.w3schools.com/tags/ref_entities.asp

Rodney9
12th September 2007, 08:22 PM
www.wolf9.org

vivid2
12th September 2007, 09:26 PM
Had a look at that site in FireFox and Safari and didn't see any spurious characters...

The doctype is wrong as you have a frameset as a container for the HTML content (?). Doctype is
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">but should be <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
"http://www.w3.org/TR/html4/frameset.dtd">

TigersharkBAS
30th May 2008, 05:52 PM
Sounds like we are having similar problems. My Safari is showing these characters on certain pages as well.