PDA

View Full Version : weird eMate 300 problem



Kallikak
3rd August 2007, 10:03 AM
Hmmm, wasn't sure where to put this question, but I figured the closest forum match for an eMate 300 was a notebook. :)

Anyway, I have an eMate 300 that appears to work just fine, except when it has been left sleeping for sometime (generally overnight). After that, when I open it up it reports "Sorry an error has occurred" followed by a very large number (I have not been able to find any reference to this particular error code in any Newton docs I have or can find online.) Once in this state, the Newton Works page I have open still works fine, but I cannot open anything else or get the Extras page to appear etc. It just keeps repeating the same error if I try. However, if I reset, it all works normally again and no data is lost. Also, it recovers from sleep without problems when the length of time is shorter.

Anyone seen this kind of problem? I'm also interested in any suggestions as to appropriate diagnostic software I could try. I have done a hard reset, but that did not solve the problem

Ken

ClockWork
3rd August 2007, 10:18 AM
What was / is the very large number ?

Kallikak
3rd August 2007, 11:00 AM
I'll have to wait until I get home from work to check it. It starts with 2 and has about 10 digits, but it didn't equal $7FFFFFFF :-)

Byrd
3rd August 2007, 01:13 PM
As with all these older Mac items - have you checked the internal backup battery lately, it could be near dead and screwing with sleep/not saving memory contents to ROM properly.

JB

Kallikak
3rd August 2007, 01:20 PM
Hah! Thats one of the first things I would consider with one of my old desktop or portable Macs, but because "I don't know much about Newton's" it didn't even cross my mind. :)

That's psychology for you - I'll certainly check it out.

Byrd
3rd August 2007, 01:27 PM
Yeah Newtons can't avoid batteries like these either :)

I assume it'd be some sort of coin lithium battery like those used in other Newtons? Not sure, not used an eMate for many years :D

JB

Kallikak
3rd August 2007, 01:29 PM
There's nothing mentioned in the service manual, but I'll try and have a proper look at the machine over the weekend.