PDA

View Full Version : Waiting for encryption to be negotiated.... huh?



yeahbut
30th June 2007, 09:14 PM
Hi everyone,

Has anyone ever seen a message like the one below? I am receiving this when I try to telnet into my TiVo's, and it's a recent thing. I don't know if it is something I have turned on accidentally or what.

TiVo's don't have any encryption, and I have only been telnetting into them for 3 or 4 years with no issues, then lately this message appears:

Bozo:~ xxxxx$ telnet 192.168.1.70
Trying 192.168.1.70...
Connected to 192.168.1.70.
Escape character is '^]'.
Waiting for encryption to be negotiated...

Encryption could not be enabled.

Now this only happens on OSX. I can telnet in from my windows and linux machines with no problems.

Anyone with any suggestions?

Thanks

yeahbut

zbaron
30th June 2007, 09:40 PM
Mac OS X's telnet is "kerberised" meaning it links in Kerberos for authentication and encryption. The manual page says a -y switch should turn off encryption.

telnet -y 192.168.1.70

yeahbut
30th June 2007, 10:22 PM
When did that happen?

purana
30th June 2007, 10:24 PM
When did that happen?

Did you install 10.4.10? by chance...

yeahbut
30th June 2007, 10:32 PM
Did you install 10.4.10? by chance...

I think this was happening prior to me installing that.

When I try the -y switch I get:

telnet: illegal option

purana
30th June 2007, 10:33 PM
I think this was happening prior to me installing that.

When I try the -y switch I get:

telnet: illegal option

Show the entire command your typing, must be a syntax problem.

My 10.4.10 machine has telnet that takes -y option and so does my 10.4.9 machine telnet binary.

yeahbut
30th June 2007, 10:40 PM
I read the man page after you suggested the -y switch. I can't see a-y switch in the man telnet page...

telnet -y 192.168.1.70
telnet: illegal option -- y
Usage: telnet [-8] [-E] [-K] [-L] [-G] [-S tos] [-X atype] [-a] [-c] [-d] [-e char]
[-k realm] [-l user] [-f/-F] [-n tracefile] [-r] [-x] [host-name [port]]

zbaron
1st July 2007, 06:09 PM
I read the man page after you suggested the -y switch. I can't see a-y switch in the man telnet page...

What version of OS X are you using?

purana
1st July 2007, 07:05 PM
Doesn't sound like 10.4 ;) must be older.

yeahbut
1st July 2007, 08:22 PM
I am using 10.4.10

yeahbut
1st July 2007, 08:29 PM
Okay I figured it out.

I have Macports installed for a couple of applications I need.

When I type in "telnet -y 192.168.1.70" it is using the /opt/local/bin telnet rather than the usr/bin/telnet.

Which opens another question, what do I have to edit to choose the usr/bin/telnet as the default?

Thanks for all the suggestions, guys, I appreciate the effort...

Thats a real trap isn't it? I mean even the man page I was getting was the Macports telnet page not the Macosx telnet man page.

zbaron
1st July 2007, 08:47 PM
Which opens another question, what do I have to edit to choose the usr/bin/telnet as the default?

Well, that was going to be my next question.

As for getting the right telnet the first time, have a look in your home directory for a file called ".profile", or ".bash_profile". In this file, will be a line like

PATH=/opt/local/bin:${PATH}

make that line

PATH=${PATH}:/opt/local/bin

Your system directories will now be searched before the macports installed /opt/local

If there is a line with MANPATH in it, you might want to change that one around too. This is the manual page search path.

yeahbut
1st July 2007, 08:47 PM
edited .profile changed the order in thepath. all fixed.

Thanks for all the input guys...