PDA

View Full Version : Has anyone got Darwine working?



forgie
30th May 2007, 01:23 AM
Has anyone here managed to get Darwine working? I've managed to get it to run a limited set of apps, but every time I run it I get this error message:

"Wine cannot find the FreeType font library. To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5."

I have installed freetype (the binary and the shared library) using fink, but I can't get Darwine to see it. I have tried making symlinks from the /sw/lib/....freetype files to /usr/lib, and all sorts of things, but nothing has worked. Any ideas?

dotnet
30th May 2007, 02:01 AM
What would wine use the freetype library for? Isn't that something for the X server to bring along? Maybe the Apple X server doesn't have it, and you need to use the proper one?

Just guessing here....

Cheers
Steffen.

forgie
30th May 2007, 02:07 AM
I don't know why it's needed. Darwine is very frustrating - obviously a huge amount of work has gone into the wine project, but the documentation is terrible. (this may not apply to non-mac wine, just Darwine)

I've spent too many hours chasing my tail trying to add symlinks to every location that I can think of that wine could be checking for freetype....

I did get Firefox 2 running, but whatever API FF uses for pixel rendering obviously doesn't work properly in wine, since all the text shows up as "un-anti-aliased", which looks incredibly ugly (almost unreadable).

thorevenge
30th May 2007, 11:26 AM
PowerPC?

I've never got it 100% working. The way I did get it working was to build WINE itself with the PowerPC hack (I can't remember where I found it) and then symlinked the Darwine app to use that build of WINE rather than the Darwine build.

And it worked - kind of...