PDA

View Full Version : M$ Word niggle



mctext
12th May 2007, 04:37 PM
OK, it's minor, I admit, but there's an odd thing M$ Word is doing.
Every time I open a new document (which is many times a day), it automatically inserts two unbreakable spaces at the top of the document.
Easy to remove with fn+delete ... but very annoying.
I once put the unbreakable space on to a keyboard command when getting text to align vertically.
(Now I just switch to a monspace font for that.)
Anyone know how to get rid of this?
I don't want to trash my Normal template because I've customised the thing to do all the peculiar things I need to do with text.

mct

mctext
12th May 2007, 05:01 PM
Bit more info I've discovered:
The standard Word shortcut for a nonbreaking space is Opt+Spacebar.
That doesn't work for me.
Instead, it inserts a capital-E with a circumflex accent!!
The following do insert nonbreaking spaces: Cmd+Shift+Spacebar and Opt+Shift+Spacebar.
Don't know if this is connected to the problem but it might help.
Also, the Customise Keyboard pane doesn't include "nonbreaking space" or "insert nonbreaking space" -- not even in All Commands.
I'm stumped.


mct

Venom71
12th May 2007, 05:34 PM
Did Word crash on you at some point recently?

I vaguely remember this sort of thing happening if Word had crashed and normal.dot was corrupted.

So maybe worthwhile recreating 'normal.dot' from scratch.

Hope this helps mate ...

:thumbup:

mctext
13th May 2007, 12:12 PM
MacPomme,
No, no actual crashes -- not for ages.
And isn't .dot a Windoze thing?
On the Mac, the settings live in the templates folder and the main one is just called "Normal".
The pain of reconstructing this, like I said, would be just too great.
Thanks though.

mct

rtc
13th May 2007, 12:56 PM
MacPomme,
No, no actual crashes -- not for ages.
And isn't .dot a Windoze thing?
On the Mac, the settings live in the templates folder and the main one is just called "Normal".
The pain of reconstructing this, like I said, would be just too great.
Thanks though.

mct

We now live in unixland, where file extensions are used (e.g. ".dot" for word templates) so long as the bundle bit is absent. As with windows, we have a "hide file extension" option.

Go into the customise toolbars screen, then go into the "keyboard shortcuts" button, and click "restore all" or whatever similar idea it actually is (can't remember exactly). This may or may not fix your issue with the keyboard shortcut for a nonbreaking space being different.

rtc
13th May 2007, 01:00 PM
*aham.* "surely" you back up your template regularly,...

mab
13th May 2007, 01:21 PM
We now live in unixland, where file extensions are used (e.g. ".dot" for word templates) so long as the bundle bit is absent. As with windows, we have a "hide file extension" option.



In Unix, extensions are only there for users to know what type a file is. Unix can tell what type a file is by looking at the headers.

rtc
13th May 2007, 02:03 PM
In Unix, extensions are only there for users to know what type a file is. Unix can tell what type a file is by looking at the headers.

Okay, but to be OSX-specific, it looks first at the bundle bit, and in the absence of one looks at the file extension.

To test this, get any file with a header (e.g. an mp3 or almost anything from adobe, but probably not many truly plain text files) and change its extension to ".url" or ".gif" or ".toast" or something that it isn't, and watch OSX try to open it with the wrong program just because you changed the file type.

mab
14th May 2007, 03:23 AM
To test this, get any file with a header (e.g. an mp3 or almost anything from adobe, but probably not many truly plain text files) and change its extension to ".url" or ".gif" or ".toast" or something that it isn't, and watch OSX try to open it with the wrong program just because you changed the file type.

Bummer; that is an OS X problem (finder I think) , The underlining (Unix) system would know the file type. test it on the command line (#>file file2test")

rtc
14th May 2007, 06:58 AM
That is an OS X problem

Yep..

mctext
14th May 2007, 01:18 PM
"surely" you back up your template regularly,...
Of course -- I have several copies, but they're all the same!
You get that with copies.
Still working on the darn thing.
But it's not the keyboard shortcuts thing that's the main problem.
That's just a possible clue to how the "new file" problem occurred.
The real trouble is that every new file starts with two nonbreaking spaces.


mct

rtc
14th May 2007, 07:14 PM
Of course -- I have several copies, but they're all the same!
You get that with copies.
Still working on the darn thing.
But it's not the keyboard shortcuts thing that's the main problem.
That's just a possible clue to how the "new file" problem occurred.
The real trouble is that every new file starts with two nonbreaking spaces.


mct

cheap nasty workaround: put the following macro in your document:

1. Select all
2. Delete

If it's a template (".dot"), put it in a new module and call the routine "AutoNew()".

If it's in a document (".doc"), put it in the "Document_Open()" routine.