PDA

View Full Version : Print (cmd-P) crashes apps



HDK
15th April 2007, 01:33 PM
Help.
Powerbook 1.67GHz 10.4.9
Every time I try to print a page of a pdf document, Preview crashes. Word will also crash if I try to print a test page. Happens from two different user accounts.
I have the drivers installed for the printer Epson Stylus C61. Originally problem occurred whilst trying to print to a shared printer, but wont work even when directly connected to printer.
Everything prints fine from my eMac. Same software.
I'm confused and getting cranky.

Currawong
15th April 2007, 01:42 PM
Can you open the crash log for preview - should be in your user folder -> Library -> Logs -> CrashReporter -> Preview.crash.log and post the headers and ONLY the thread that crashed (it will have "Thread X crashed" where X = the thread number at the top of that thread).

Probably it's a font issue, but no harm in having a look. Shotgun test fix is to try printing as another user - if that crashes then remove any fonts you've added to the system "Library/Fonts" and try again.

HDK
15th April 2007, 01:51 PM
Let me know if you need any more. There 's plenty of it...
Have tried the second user acc already with same results.
And I don't believe any extra fonts have been installed, I only recently reinstalled Tiger.

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x0000000c

Thread 0 Crashed:
0 MediaPlugIn 0x051fa704 OpenCommonMediaPlugInResource + 44
1 ....pde.PrintSetting.C61Series 0x05556b8c UIGetMediaResource + 108
2 ....pde.PrintSetting.C61Series 0x055554f0 New__18UIPrintSettingPane + 2552
3 com.epson.print.UIInterpreter 0x05575928 NewIPP__8UISystem + 712
4 com.epson.print.UIInterpreter 0x05573310 NewIPP + 44
5 ....pde.PrintSetting.C61Series 0x0554e144 Initialize__12PrintSetting + 40
6 ....pde.PrintSetting.C61Series 0x0554d2f8 Initialize + 216
7 ...int.framework.Print.Private 0x054a3240 PrinterPopupEventHandler(OpaqueEventHandlerCallRef *, OpaqueEventRef*, void*) + 1012
8 ...int.framework.Print.Private 0x05494c60 DeallocPageSetupDialogHandlerTimer(__EventLoopTime r*, void*) + 1392
9 ...int.framework.Print.Private 0x0549639c DeallocPageSetupDialogHandlerTimer(__EventLoopTime r*, void*) + 7340
10 ...int.framework.Print.Private 0x05495150 DeallocPageSetupDialogHandlerTimer(__EventLoopTime r*, void*) + 2656
11 ...int.framework.Print.Private 0x05495800 DeallocPageSetupDialogHandlerTimer(__EventLoopTime r*, void*) + 4368
12 ...int.framework.Print.Private 0x0549b638 PMPrivateSetItemProc + 1096
13 ...int.framework.Print.Private 0x0549c008 PMPrivateSetItemProc + 3608
14 ...int.framework.Print.Private 0x0549ace4 PMPrivatePrepareAppKitPrintDialog + 228
15 ...apple.print.framework.Print 0x9311d448 PJCPrepareAppKitPrintDialog + 124
16 ...apple.print.framework.Print 0x9311d360 PMPrepareAppKitPrintDialog + 128
17 com.apple.AppKit 0x93975fd4 -[NSPrintPanel beginSheetWithPrintInfo:modalForWindow:delegate:di dEndSelector:contextInfo:] + 276
18 com.apple.Preview 0x0003b420 0x1000 + 238624
19 com.apple.AppKit 0x9381ec4c -[NSApplication sendAction:to:from:] + 108
20 com.apple.AppKit 0x938794b8 -[NSMenu performActionForItemAtIndex:] + 392
21 com.apple.AppKit 0x9387923c -[NSCarbonMenuImpl performActionWithHighlightingForItemAtIndex:] + 104
22 com.apple.AppKit 0x93878ce4 -[NSMenu performKeyEquivalent:] + 272
23 com.apple.AppKit 0x938788c4 -[NSApplication _handleKeyEquivalent:] + 220
24 com.apple.AppKit 0x93782408 -[NSApplication sendEvent:] + 2944
25 com.apple.Preview 0x00003620 0x1000 + 9760
26 com.apple.AppKit 0x93779d10 -[NSApplication run] + 508
27 com.apple.AppKit 0x9386a87c NSApplicationMain + 452
28 com.apple.Preview 0x000313d0 0x1000 + 197584
29 com.apple.Preview 0x00031278 0x1000 + 197240

marc
15th April 2007, 01:52 PM
How about Adobe Acrobat Reader? Can that print the doc?

I agree with Currawong that font(s) might be the cause. Either that or a dodgy driver.

ClockWork
15th April 2007, 02:02 PM
HD - try booting into Single User Mode:

Apple-Command :cmd: + S on reboot and hold down till white text appears - let scroll for a bit... and then after root# type:

/sbin/fsck/ -fy

and hit return key - and then see if it shows up anything strange after:

**Checking Catalog File**

Any file modifications ?

cw

HDK
15th April 2007, 02:28 PM
CW, no file modification results.

Marc, DL acrobat now.

HDK
15th April 2007, 02:39 PM
Acrobat Reader crashes too.

Currawong
15th April 2007, 05:38 PM
Hmm, first thing is "MediaPlugIn" - have you got the latest driver from Epson on the net or did you use a CD that came with the printer to install the driver? I'll bet if you look in the hard disk in Library in Printers or some-such there will be this file somewhere with that name.

HDK
15th April 2007, 06:17 PM
Currawong,
I tried reinstalling the drivers from a file I keep that has always worked in the past which I originally downloaded from epson. This didn't work.
I just went back to epson and there was an updater for tcp/ip printing and a recent new driver. I installed the tcp/ip updater but didn't fix the problem.
The other driver required my Macintosh to have a Pentium CPU... this I will notify epson of...

A spotlight search returned no results for "mediaplugin" nor manual folder search.