PDA

View Full Version : Help Needed with Embedding .mov into html with IE



kudos
6th January 2005, 11:09 AM
Hey guys,

I inserted a little .mov into my weblog:

http://www.psycho-central.com/weblog.htm

which is of my gf skydiving.

I got the source code from here:

http://www.sonoma.edu/it/websupport/faq/qtcode.html

The embedded .mov displays just fine in all 4 of my browsers on
the mac: Safari, Firefox, OmniWeb & Internet Explorer

but

It does not display when viewed with IE on a PC, I can't figure out why?

Here is the exact code:

<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" codebase="http://www.apple.com/qtactivex/qtplugin.cab" width="240" height="196" hspace="10" vspace="10">
<param name="src" value="Images/Peg Skydive.mov" />
<param name="controller" value="true" />
<param name="pluginspage" value="http://www.apple.com/QuickTime/download/" />

<embed src="Images/Peg Skydive.mov" width="240" height="196" hspace="10" vspace="10" controller="true" autoplay="false" pluginspage="http://www.apple.com/QuickTime/download/indext.html">
</embed>
</object>

I ended up simply linking to the file, to display the .mov in a new window which
works fine on x86/Win/IE.

Can anyone help? What do I need to add/modify to get the file to
display embedded in IE on the PC......

Cheers,
Lee

Disko
6th January 2005, 11:49 AM
How odd. i can&#39;t see anything wrong with that.

fyi: here&#39;s apple&#39;s help page on it: http://docs.info.apple.com/article.html?artnum=61011

But you&#39;ve done everything right?

kudos
6th January 2005, 04:27 PM
I found out what the problem was.

For some reason IE on the PC doesn&#39;t like embedding video
within a table. If I move the code out of the table it was in,
it works fine.

I didn&#39;t think I could dislike IE more than I did - but now I do &#33;

Kudos