PDA

View Full Version : Possible 802.11n Problems



gehenna
14th March 2007, 03:24 PM
hi everyone

I have a linksys wrt300n 802.11n router and an imac that has had its 802.11n enabled.

i am getting a great connection on the imac for browsing the net and downloading etc.

i have a media center in the lounge with a belkin 802.11n usb adapter which also works perfectly.

however, if i try to access my shares on the media center from my imac, i get timeouts and broken connections on my internal network every 20 seconds or so. say i try to copy a file from the imac to the media center that is 350mb (3 guess what type of file it is!), i manage to copy around 150mb then it drops the connection.

if i connect to the media center using a remote desktop connection, i have the same thing happen. however if i have the mac wired to the router i get a stable connection. also, if i connect to my router from work using a remote desktop connection to the media center i can get a stable connection. so i've isolated the fault to the imac.

i can see using the airtrafficcontrol widget that my connection can sometimes fluctuate from 54mbps to 130mbps up to 160mbps. then down again then up again, with the space of a minute sometimes.

could this be the airport card? the airport driver? a conflict with my router and my mac? its very frustrating! using my macbook i get a constant 54mbps connection and can connect to the media shares successfully with no drop out.

any wifi whizzes out there have any ideas on this one? i could try upgrade the firmware on my router, but it is brand new and it works perfectly with all my other hardware except the imac.

ps i downloaded 10.4.9 today (ahh the memories, doesnt seem that long ago since 10.3.9!) and am currently testing the connections, will update if i find any improvement.

thanks heaps