PDA

View Full Version : How do I disable font smoothing in Tiger?



rtc
7th March 2007, 04:43 PM
Hi guys

How do I do it?

I'm sure there is a setting somewhere, but it probably isn't available to regulare Tiger GUI users, only Unix geeks. Typical of OSX.

I can use terminal or pilot or cocktail or whatever, that's fine if that's what it takes.

I've found the setting for "how much font smoothing do you want" in the system preferences, but it doesn't give me "none at all thanks" as a possible choice.

By font smoothing I mean anti-aliasing.

And I don't mean just in some apps or just in the finder, I mean system-wide, and I mean forever.

Bloody LCD screens. More desk space, less harmful radiation, less power consumption, higher definition, more expensive, more blurry, more blindness. I've yet to find an LCD screen that's as good on the eyes as a top quality CRT in this regard. Whereby native res is aligned with physical size and font smoothing can be used without damaging your eyes.

Byrd
7th March 2007, 05:18 PM
Tinkertool lets you disable font smoothing to a specified point size;

http://www.bresink.com/osx/TinkerTool.html

... it does look shithouse though :)

JB

forgie
7th March 2007, 05:46 PM
OK, I've done a bit of digging..... if you open Terminal, you can manually set the "Turn off text smoothing for font sizes X and smaller" setting (which appears in System Prefs -> Appearance, down the bottom).

If you set it to something huge (like 100) then all text that is smaller then 100 points (99.99% of text) will not be anti-aliased. This applies to most native OSX widgets (Cocoa, Carbon etc) but doesn't seem to apply to OSX built-in text like menus, window titles etc. Perhaps if you restart OSX might stop anti-aliasing....

To set the level manually, go into Terminal.app and type:

defaults write NSGlobalDomain AppleAntiAliasingThreshold 100

Then hit Return. The above command set it to 100. To set it back to a "normal" setting, the easiest way is to go into the Appearance PreferencePane and choose a value from the drop-down box that I mentioned above.

rtc
8th March 2007, 06:25 PM
Cheers all.

THis option turns off font smoothing in desktop icons, some application text and a few other things.

It does not come anywhere near close to turning it off system wide. This text i am typing is smoothed, so are all my menus, so is a heap of app text (many apps have some stuff smoothed and some not).

What rot.

I'll just turn it back on and sue Apple when I go blind.

Thanks anyway.

marc
8th March 2007, 06:29 PM
:o I have no idea why you'd think turning off anti-aliasing would be a good thing! I find non anti-aliased text much harder to read (and uglier).

ClockWork
8th March 2007, 06:46 PM
Usually, text / type elements go blurry at lower screen resolutions, on those Flat Active-Matrix Liquid Crystal Displays.

What size (in inches) display unit have you got there, Rtc ?
And what Resolution have you got it set to?

cheers,

cw

Danamania
8th March 2007, 06:49 PM
It does not come anywhere near close to turning it off system wide. This text i am typing is smoothed, so are all my menus, so is a heap of app text (many apps have some stuff smoothed and some not).

I'm pretty sure one of the unsanity.org haxies allowed you to turn off all font smoothing, everywhere. can't for the life of me remember just which one (it may have been Silk, though its main purpose is to put antialiasing everywhere) as I tried it and immediately went back to antialiasing, but take a peek around there.

Dana

rtc
8th March 2007, 06:50 PM
No no you're all absolutely right it's actually my wierd wonts that are at play here.

I have a 19" viewsonic set to its native resolution of 1280x1024. I used to have a 15" apple multiscan diamondtron CRT (graphite case) which was much much clearer than any LCD i've ever seen.

As a result of this LCD issue, (see my earlier post where I mentioned it), things that look OK on a CRT look shit by comparison (not shit, just shit by comparison) on an LCD. Starting with, but not limited to font smoothing.

Danamania
8th March 2007, 06:55 PM
As a result of this LCD issue, (see my earlier post where I mentioned it), things that look OK on a CRT look shit by comparison (not shit, just shit by comparison) on an LCD. Starting with, but not limited to font smoothing.

For what it's worth, I've just started regularly using a laptop - I turned antialiasing off too for the same reason (though I'm on Mac OS 9). Normally I'm on one of a bunch of CRTs where I turn antialiasing on everywhere I can.

Dana

rtc
8th March 2007, 08:33 PM
Yeah don't get me started on laptop screens. Edit: or laptops in general for that matter.

I'm tempted to try the hack, but I don't think I will bother as the problem is really having an LCD instead of a CRT, bad display of font smoothing seems to be a symptom of this rather than the cause of the badness. Thanks anyway though.

mac_man_luke
8th March 2007, 10:54 PM
19" LCDs have huge pixels which wouldnt help at all

17 and 20" LCDs have far smaller pixels in general

eg most 17" LCDs run at the same resolution as 19" LCDs

bartron
8th March 2007, 11:08 PM
There are 2 types of font smoothing for LCD's. One is regular anti alised fonts where the smoothing happens on a per-pixel basis regardless of resolution, and the other is sub-pixel where the smoothing happens on sub-pixels (3 per pixel) at the native resolution of the LCD. This latter type happens naturally when you run a CRT. I hate it becasue it gives text a red/green 'shimmer' on LCD screens...looks ok on my macbook pro screen but like crap on my 19" Dells.

Bartron

forgie
9th March 2007, 12:00 AM
Just to make sure: you did re-launch your apps after trying my suggestion, right? OSX apps load settings like that on launch, so if you didn't re-launch then you wouldn't notice a difference.

forgie
9th March 2007, 12:03 AM
Ok, I just tested it for myself, and SOME things change with this setting:
595

596

mjankor
9th March 2007, 04:01 AM
Ahhh!!! My eyes!!!

rtc
9th March 2007, 06:36 AM
Yeah i relaunched the whole machine.

Squozen
9th March 2007, 06:57 AM
Unsmoothed fonts look hideous in OS X, you'd really need to go back to OS 9 and bitmapped fonts to have a tolerable display without anti-aliasing. OS X renders fonts on the fly and has the best smoothing of any desktop OS that I've seen.

Byrd
9th March 2007, 07:52 AM
rtc why not just pickup a cheap CRT? Visit any swap meet and you'll be able to score a 20 - 21" Trinitron for under $100, or online - they're that cheap now (sad).

JB

forgie
9th March 2007, 08:34 AM
I'm not sure I fully understand why you actually want to turn it off - do you have a 19" LCD with a high pixel pitch?

OSX's Anti-aliasing is.... I would consider it to be almost beautiful. XP looks really bad after using OSX for a while.

Currawong
9th March 2007, 09:56 AM
rtc: Are you using a screen connected via VGA or DVI? I gather ones connected via the former appear rather more blurry than the latter.

mjankor
9th March 2007, 11:47 AM
I'm not sure I fully understand why you actually want to turn it off - do you have a 19" LCD with a high pixel pitch?

OSX's Anti-aliasing is.... I would consider it to be almost beautiful. XP looks really bad after using OSX for a while.

I second that. On a few of the windows laptops I've used lately Windows cleartype almost seems to create undulating shades of grey through the text depending on the slope of the letters. The only machines I've seen where the cleartype works well is on my old Windows laptop which has a 1024x768 15" screen.

RTC have you tried the different font smoothing options under appearance in System Prefs. OS X actually has 4 levels of font smoothing. It may pay to try them out.