PDA

View Full Version : Backspace in Frets on Fire



WMC
23rd February 2007, 09:28 AM
Wasn't sure whether to post this in the Games forum. I figure it's more of an OS X configuration issue, so here goes:

I've been playing the truly amazing Frets on Fire (http://louhi.kempele.fi/~skyostil/uv/fretsonfire/), an open source Guitar Hero-esque game for Windows, Linux and (woo-hoo!) Mac.

The Mac version runs flawlessly, with two exceptions: I can't get it to import tracks from the Guitar Hero 2 Playstation2 disc like it's supposed to (solved by digging out an old W2K laptop), and secondly, the backspace key doesn't work properly. That means I can't edit my name to enter high scores; as different people play and try to backspace to enter their own names, a square appears every time the key is pressed. As a result, the default high score name is now something like WMC[][][][]\[]/[]d[]D[]\, and can't be changed.

Stuff I've tried:

- setting terminal.app's emulation to VT100;
- setting terminal.app's Window Settings to "delete key sends backspace";
- using different key combinations for backspace (eg ctrl-, shift- and command-d, ^H etc);
- installing DoubleCommand (doesn't seem to have an option for mapping Delete to send unicode Backspace); and
- running Frets in an xterm through X11.

Any tips? A line I can stick in my XML keyboard config? Intel 2Ghz Core Duo iMac, if it matters. Thanks!