PDA

View Full Version : Forcing Airport to join?



MarkR7
30th December 2006, 09:33 AM
Hey lads,

Just a quickie, Im using the inbuilt wireless on my new MBP, i havent had a problem before but now every time i start up/come out of sleep i have Right-click on the wifi symbol and click on my wireless network name.

Absolute pain, plus im on an Active Directory (with login tied into that), so it adds a couple of minutes to start up time.

Anyone have any ideas? I've tried the 'preferred networks' thing in prefs. Still same symptoms.

Can anyone help!?

TLCAUS
30th December 2006, 09:41 AM
I know the feeling, its been happening t me since i upgraded to 10.4.8, prior to that, it was fine, i have searched macfixit.com etc, and it appears to be a common problem, the only solution i have found it to make sure you have set your HD not to sleep ( in the energy saver control panel) if thats switched on it will do it over and over, if its switched off its not usually a problem unless you reboot

purana
30th December 2006, 09:52 AM
I think I know the problem you guys are talking about, normally when the machine turns on or comes out of sleep you'd expect it to rejoin the AP/wireless network it uses all the time (without the need to select it each time).

I found after updating from a previous patch it stopped doing this. My solution was to remove the wep/wpa key/password for our AP from the keychains, then goto the system prefs, network, then show "airport", then by default, join: preferred networks... go remove all the entries displayed below in the box.. including your wireless network at home.

click apply. Now change the by default, join: preferred networks, back to automatic.. apply again.

Now close all those windows up, then goto airport icon on the menu bar, and select your AP again. Enter in the details for the wep or wpa key. Making sure you click remember password in my keychain.

Now confirm that once joined if you restart the machine or sleep and unsleep it (it will rejoin without be manually asked to do so).

MarkR7
30th December 2006, 10:06 AM
Hrmm i thought i had it there for a minute, but alas.. Dissapointment..

I too beleive it happened after the latest security update..

I have no problem with my computer sleeping, and rejoining isnt too much of an issue.. But waiting 5 mins for AD auth when no network interfaces are active, seems a bit much to me.

TLCAUS
30th December 2006, 10:09 AM
did you have any luck with purana's idea, i havent tried it yet but i am about to

MarkR7
30th December 2006, 10:11 AM
Ahh!

I just tried something, and it seems to have worked!
If you have parallels installed - go and disable the 'virtual connections' in system prefs > network > network port configurations (under 'Show').

PITA i know, especially if you use networking on windows etc. Buti'd prefer to re-enable that when necessary, rather than re-enabling airport all the time.

TLCAUS
30th December 2006, 10:20 AM
Nope no joy here, once i reboot i still need to reconnect to my airport

MarkR7
30th December 2006, 10:21 AM
Try my thing or Purana?

Mine's working flawlessy now :p

TLCAUS
30th December 2006, 10:24 AM
No parallels, dont want to ruin a good mac with crappy windows problems, i went through enough of those is My DOS days, No way i am going back :p