View Full Version : "beamsync -d" enabled at login -- help

9th April 2006, 06:28 PM

I am sure that there is a way to execute the command beamsync -d at the time of startup or login.

For some reason, when you type beamsync -d into terminal, exposť becomes silky smooth and very gorgeous.


9th April 2006, 08:16 PM
What's beamsync? It's not Apple software, I can't find it on my computer.

9th April 2006, 08:31 PM
Same, I keep getting command not found

9th April 2006, 09:19 PM
Have either you got the developer tools installed? I think it's related to Quartz Debug. I don't have them installed at the moment so I can't check.

9th April 2006, 09:21 PM
I have developer tools installed and i dont have beamsync

10th April 2006, 12:00 AM
Nor I, crazy-man.

10th April 2006, 12:30 AM
You can find the Beam Sync Tools in Quartz Debug - Tools -> Show Beam Sync Tools

Not sure about this command line executable though, never heard of it.

10th April 2006, 12:36 AM
Google pointed me to: http://www.macosxhints.com/article.php?sto...050622224239730 (http://www.macosxhints.com/article.php?story=20050622224239730)

Which points to a command line tool availble from here:

scottgrot: You could automate it using a shell script or automator, but you might as well use the defaults write command listed in the macoxhints.com article's comments.

17th April 2006, 11:08 AM
Sorry for the belated reply, I have been out of range for a week.
Thanks teej. After your post I realised that I should have done another search.

Origanally I saw the "beamsync -d" hint on macosxhints.com

I just did another search on osxhints and came up with this thread.

http://www.macosxhints.com/article.php?sto...&query=beamsync (http://www.macosxhints.com/article.php?story=20050622224239730&query=beamsync)

Scroll down to the article by unagi and he tells you the code to type into terminal.


The thread also explains what beamsync does, and what may happen if it is turned off.

17th April 2006, 12:03 PM
From that thread:

found the defaults to change: use this console cmd:
sudo defaults write /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates 0 You can verify this by opening /Library/Preferences/com.apple.windowserver in Property List Editor and expand "Compositor"

Open Quartz Debug and reveal the Beamsync tools. change the setting.

Reopen /Library/Preferences/com.apple.windowserver and expand Compositor to see the new setting.

0 = disable beamsync

1 = Auto beamsync

2 = force beamsync

Certainly makes the frame-rate faster on a G5 with a GeForce 6800.