PDA

View Full Version : Auto Login not working



admiral31
15th February 2006, 08:47 AM
Hi

Got an annoying problem. Just got a new G4 iBook that I want to automatically login to everytime it starts up. Set up Username and password when it was fired up for the first time. It now keeps prompting me to login after every restart. I went to accounts and login options and selected the auto login (which is what I have set on my G5 iMac), but when I restart, it asks me to login again. There is only one account set up (admin). I tried resetting the password using the install disk, but that had no effect either.

Am I missing something really simple here? Can anyone suggest a solution?

Thanks

hawker
15th February 2006, 08:55 AM
Have you slected auto log in in system prefs?

admiral31
15th February 2006, 09:01 AM
Yep, auto login is checked in system prefs. Even after I restart and login again, I go straight to prefs and check it, and it's still selected!

hawker
15th February 2006, 09:03 AM
Originally posted by admiral31@Feb 15 2006, 08:31 AM
Yep, auto login is checked in system prefs. Even after I restart and login again, I go straight to prefs and check it, and it's still selected!
You using Tiger? does the drop down menu next to "auto login as" selected to you, the user?

admiral31
15th February 2006, 09:11 AM
Yes, sorry, using Tiger. Drop down menu only has one option (me), which is also the admin account.

Disko
15th February 2006, 09:20 AM
Since a picture is worth 1000 words...

Are both of these options in sys prefs set correctly?

http://users.on.net/disko/loginprefs.jpg

Aa
15th February 2006, 09:26 AM
Yep what disko said,

and also, i know it sounds silly, but do you 'log out' or 'shut down'?
I 'shut down' and never have any login issues.

Squozen
15th February 2006, 09:53 AM
Open Netinfo Manager, select / -> users -> yourusername, then try re-entering your password? Only thing I can think of is that the password stored is corrupted somehow.

By the way, I would recommend NOT allowing a laptop to start up without a password. If it's stolen, the thief has access to all your personal information, which is not a good thing.

admiral31
15th February 2006, 09:54 AM
I shut down. My "accounts" pane is set up as per Disko's example. I have not touched file vault, but shouldn't "disable automatic login" be unchecked? (since I want to automatically login). I tried restarting with it checked and unchecked, and still had the same login window appear.

I don't know if it makes a difference, but the login window has two options: one is my name (which I click and then enter my password) and the other is just called "Other" which if I select prompts me for a name AND password. But in the accounts pref there is only one user, which is me.

Squozen
15th February 2006, 10:00 AM
Something's broken... if it's brand new I'd boot from the OS CD, format and reinstall. Takes 30 minutes and guarantees to fix all problems. :)

Disko
15th February 2006, 10:03 AM
yeah - the 2nd part of my image isn't the correct setting. (i just didn't untick it for the screenshot, as i was only showing you where to look)

admiral31
15th February 2006, 10:07 AM
Cheers, thanks for your help everyone. I think I might just do a complete reinstall!

admiral31
15th February 2006, 10:30 AM
Strange.....was just about to reinstall. Gave Squozen's idea of checking the password in Netinfo Manager a go. Entered the password there, and it worked, obviously. Went back to Accounts pref, and Auto login was now unchecked and pull down menu blank. Ticked the box, selected my name, restarted and BAM, no login required! So looks like problem solved.

Thanks a bunch, Appletalkers!