PDA

View Full Version : The latest saga with my Macbook Pro



Oldmacs
20th May 2015, 10:00 PM
Hi all,

Last week my Macbook had its screen(2nd time) + logic board(3rd time) and Optical drive(2nd time) all replaced at the genius bar. Upon taking it home I've now got charging problems.

Quite frequently the battery status changes to "Battery not charging". There is no pattern for this, it happens at random intervals and across 4 different chargers. I've also cleaned the port with a cotton bud and this hasn't improved anything. Once the battery stops charging, the MagSafe light turns off as well. To fix it a large amount of unplugging and replugging is usually needed.

Any ideas anyone??? This has never been a problem till the day after it came back from the genius bar.


I know I will have to take it back to get it serviced, but I can't do so for a couple of weeks due to a really busy schedule... so I was just wondering if anyone has ever seen this before.

Its a Mid 2012 non Retina Macbook Pro standard configuration with an upgraded 1 TB HD + 8GB of ram.

Dog Knight
21st May 2015, 12:52 AM
Haven't seen it before.
When fiddling with a MBP I have lying around (2010), I bugger the battery's connection to the motherboard and now it can only be run off mains. Its a fairly flimsy connection so I suppose its possible that connector is loose.
Sorry, thats all I can really think of.

The_Hawk
21st May 2015, 08:52 AM
I'm grasping at straws here, but what port is on that laptop (Magsafe 1 or 2?) and what charger are you using?


In my case I have the MagSafe2 port which *always* works just fine with the MagSafe2 charger I have, but when I use my 27" Thunderbolt display it only has MagSafe1 so requires one of those little dicky adaptors. The problem with them is they seem to last about 6 months or so before packing it in (I've been through 3 or 4) and they have the symptoms you are reporting.

From what I understand it must be one of the internal connections breaking and because this "smart" charger needs to know it's plugged in to ramp up the power when one of those extra lines passes that information to the MacBook. (Unlike "normal" computers which just blindly throw power out down a two pole power connector). It could be one of the internal connectors on the port or the motherboard with a dry joint or similar.

The Guv
25th May 2015, 05:39 PM
Stupid question but is the charger the right wattage? If the GB did the upgrades perhaps they've nudged something. Done all the PRAM etc stuff?

Oldmacs
25th May 2015, 09:25 PM
Stupid question but is the charger the right wattage? If the GB did the upgrades perhaps they've nudged something. Done all the PRAM etc stuff?

Yep - happens across 4 correct wattage chargers.

Genius bar did the repairs...

My Mac is now back to shutting down randomly - it just cuts power and restarts. The same that happened before the Logicboard + screen + optical drive replacement.

Getting annoyed with going to the genius bar...

littleblightie
15th June 2015, 12:47 PM
I would suggest calling AppleCare and explaining the situation, including detailing all the repairs/replacements thus far. They seem to have a lot more delegation in relation to repairs/replacements.