PDA

View Full Version : Open Apps Not Appearing on the Dock???



b00
17th September 2014, 04:09 PM
Hey Guys,

When i have apps open they don't appear on the dock as being open. If i open an app that lives in my applications folder that doesn't have a icon permantenly on the dock it doesn't even appear on the dock.

For example:

http://i.imgur.com/JClr4Wp.png (http://imgur.com/JClr4Wp)

How do I fix this?

Shanks in advance

glacierdave
17th September 2014, 05:01 PM
What version of OS X?

From what I can tell of your screenshot it's not actually placing an indicator beside much of anything (except Finder). Check System Preferences -> Dock and see if there's a check mark for "Show indicator lights for open applications" (that's on Mavericks, anyway, don't have anything older handy to check the correct option but I think it's in much the same place).

David

b00
18th September 2014, 08:19 AM
What version of OS X?

From what I can tell of your screenshot it's not actually placing an indicator beside much of anything (except Finder). Check System Preferences -> Dock and see if there's a check mark for "Show indicator lights for open applications" (that's on Mavericks, anyway, don't have anything older handy to check the correct option but I think it's in much the same place).

David

Running mavericks. In system preferences the box is ticked, but still doesn't have the indicator light. What is more annoying is the fact that apps that aren't locked to my dock, don't appear on the dock when opened. Making it quite confusing having all these windows open but no icons :?

BradMacPro
20th September 2014, 11:29 AM
Open ~/Library/Preferences/ and remove both com.apple.dock.plist and com.apple.dock.db, log out and back in. Do you have some 3rd party Finder/Dock extension like XtraFinder or TotalFinder. Obsolete ones can cause a problem like this.

snowy
20th September 2014, 11:38 AM
This indicates there is a fault / corruption in your Dock.

Quit all running Applications.
Then:

Relaunch the Dock:

1. Open Terminal.app in your Applications > Utilities
2. Copy & Paste this command

killall Dock

3. Hit Return
4. Quit terminal.

See if this solves your problem.