PDA

View Full Version : iMessage on multiple devices



laughingbird
13th May 2013, 01:25 PM
Recently I have been experiencing some inconsistency in the arrival of iMessages. I have iMessages activated on three devices, an iPhone, an iPad, and my desktop Mac, although I seldom use it on the iPad. A couple of times recently when someone has texted me using iMessage, the message has appeared on my Mac, but not on my phone. This is not just a delay. One of them I'm looking at arrived on my Mac three days ago and still isn't showing on my phone. There are other messages in a thread from the same sender, and they all show on both devices, but there is this one message that doesn't show on the phone.

In an iMessage conversation with a different person today, the conversation was initiated by them, but didn't show on my phone. I replied initially from the Mac. I received another message from her, which flashed on my screen in notifications, but no number badge appeared on the messages app. When I opened Messages, it was there, but it still hasn't appeared on my phone. This time I decided to send a reply from my phone (which my phone had to treat as a new thread because it wasn't showing any prior messages from this person). My reply immediately showed up in the thread on the Mac, but it is still the only entry showing in that thread on the phone.

This is obviously a problem, because I'm not always at my desk, so it is more important that messages get to my phone than to my desktop.

Has anyone else been experiencing this problem? I first noticed it last Friday, so that is since the most recent iOS update.

And does anyone have any suggestions for how to trace and correct the problem.

kyte
14th May 2013, 06:59 AM
Yes, happens to me as well. I've never found a solution and its been happening since iMessage began. I've learned not to fret over it.

Devil
14th May 2013, 07:57 AM
Are all your devices setup with 'start new conversations from:' set as the same thing? ie. from the same phone number or email address.

laughingbird
14th May 2013, 10:43 AM
Are all your devices setup with 'start new conversations from:' set as the same thing? ie. from the same phone number or email address.

I'm not sure if this was the problem, but it is possible. Some of the known missing messages were in threads that I didn't start, so my "start from" settings shouldn't have made any difference. However, when I went to check on this, the setting on my phone was different. For some reason, it didn't even show my phone number as an option for the "start from" setting. The phone number was a set "start from" option on my Mac and my iPad, which both seem to be getting everything okay, but it wasn't even showing in the list of possibilities on the phone. I turned iMessages off on the phone, and then back on again, and now the phone number shows up properly in the options and so has been selected. They are now all the same.

Whether that has fixed the main problem, I'm not yet sure, although I do know that it hasn't synced the previous messages, because they still show on my Mac and iPad but not on my phone. I'll wait and see what happens with new ones.