PDA

View Full Version : Mountain Lion 10.8.3 sleeping despite active processes!



simonm
23rd April 2013, 07:45 PM
Has anyone else noticed that OS X 10.8.3 is sleeping when there are active background processes? Is this a bug?

I'm doing a lot of text processing that's taking hours but I keep finding that the computer has fallen to sleep with the work unfinished when I'd obviously prefer it to finish processing so it's pretty frustrating. Yes I know I can set the sleep setting to "never" but this is not a fix for the long-standing and superior behaviour where OS X intelligently determines if there are active background processes that override the sleep settings.

Am I missing something obvious? It doesn't matter what the work is, it could be downloading or ripping in Handbrake and OS X is still falling asleep half way through. I'm on an Early 2013 15" rMBP 2.8.

baobab68
23rd April 2013, 10:52 PM
In a pinch you can try the app "Caffeine" - creates an icon in the menu bar where you can toggle sleep on or off.

simonm
24th April 2013, 12:01 AM
Thanks for that.

Some digging around (on an unrelated matter) and I found this thread (https://forum.handbrake.fr/viewtopic.php?f=5&t=24947) in the Handbrake forums.

Basically, this bug is a "feature" of OS X ML and many developers are getting caught out because they have to implement new code within their applications to prevent the system from sleeping when they're busy, something that was never a problem in Lion.

I don't know why Apple decided to "fix" what wasn't broken; maybe it's somehow related to changes necessary for the Power Nap functionality in ML? I guess most developers will get around to fixing their apps eventually, but it's kind of annoying from an end user perspective until they do.

dappleone
24th April 2013, 08:22 AM
I find that I have to use this little, freeware utility for pretty much any task that might take a while - works great for me
Download Jiggler for Mac - Prevent screensaver and screen mode activation. MacUpdate.com (http://www.macupdate.com/app/mac/12728/jiggler)

nibbles
24th April 2013, 08:25 AM
I've noticed it going to sleep whilst burning DVDs with toast, rendering them useless. Now whenever I open toast or handbrake I switch the sleep settings to never.