PDA

View Full Version : MacBook Pro Internet Woes



PCescapee
16th January 2013, 10:28 PM
Hi I have a 13" MBP, and my wife a 15". Both purchased late 2011/early 2012. My wife's frequently takes ages to load a website, yet I can be next to her on the home wifi and connect to the same site instantly with my Mac or iPad.

Have checked all settings on both Macs and they are identical.

The matrimonial strife is causing me headaches!

Any suggestions, or does she have a dodgy Mac?

Thanks

jsarchibald
16th January 2013, 10:39 PM
I suppose you could try a few things - try a different browser, restore from a backup, the usual. I recently had my wife's MBP show a spinning beachball for everything, which made no sense as it was better spec than mine. I swapped the HDD and it fixed it straight away.

Might also be a good idea to download Geekbench and see if there are any hardware deficiencies.

Oldmacs
16th January 2013, 10:56 PM
What operating systems are these running- If memory serves me right some variants of Lion did weird things in terms of the internet- I specifically remember the internet being stupidly slow on my Macbook while running maybe 10.7.1 or .2? I think it was a wifi bug. Have you also tried plugging straight into the router with an ethernet cable to see what happens then?

glacierdave
17th January 2013, 07:48 AM
Can you test using an ethernet cable instead of Wi-Fi?

Have you tested using a different web browser?

Have you tried creating a new user profile and testing on that profile instead?

Do you get the same results no matter where the computer is situated?

Is it an intermittent fault or continuous?

David

PCescapee
17th January 2013, 09:13 AM
What operating systems are these running- If memory serves me right some variants of Lion did weird things in terms of the internet- I specifically remember the internet being stupidly slow on my Macbook while running maybe 10.7.1 or .2? I think it was a wifi bug. Have you also tried plugging straight into the router with an ethernet cable to see what happens then?

Thanks. Both running OS X 10.7.5. Mine is i7@270GHz, 2 cores, 4 threads, wife's is i7 @ 3.2GHz, 4 core 8 threads.

Ran Geek Bench as suggested by JSArchibald: her processor scores better than mine, but her memory and stream is lower, though not by that much.

Next step is a visit to the Mac Store tonight, see what they say, then I will try cable connection and new user profile.

Hard to say how often it happens - my wife complains about it late afternoon, but that's mainly when she uses her Mac, it's coincidentally when my ISP seems to slow down, but having said that I don't suffer the same issues. Still not enough to send me back to a PC yet!

PCescapee
17th January 2013, 09:15 AM
Sorry typo in previous post - wife's is 2.2GhZ

PCescapee
18th January 2013, 10:33 AM
Update on my slow connection: Mac Store checked out the MBP and all fine with hardware. They told me to do a disk permissions repair (supposedly similar to a PC defrag). They also showed me how to check the wifi channels and how to choose between 2.4 and 5 GHz, so I will monitor closely.