PDA

View Full Version : iMessage has finally been fixed!



savas
12th September 2012, 02:17 PM
Apologies if this is common news already, but I can confirm iMessage has finally been fixed in the latest 10.8.2 beta. Messages sometimes sync out of order, but at least they're all there, and Messages has phone number caller ID as it should've from the beginning.

Not that it's much of an issue, but hopefully older messages will sync over some day, or if there comes a way to merge them over from iOS devices.

VK55
24th September 2012, 05:40 PM
mine doesn't..

nike1
24th September 2012, 10:26 PM
my imesssage today was sending their reply to my laptop...but not my phone..
which was rather irritating.. i think ive fixed it..

apparently imessage on my phone was turned off...

savas
24th September 2012, 10:31 PM
Mine stopped syncing briefly when I restored from backup to my new iPhone. I think it was because the old iPhone hadn't been wiped yet, or because the iPhone 5 hadn't been reassociated with my Apple ID.

Peter Wells
24th September 2012, 10:54 PM
Mine's working too! But based on some of the feedback on twitter, we may be in a very lucky group. I think the key is to have caller id and "start conversations as" as the same on all devices.

savas
24th September 2012, 10:58 PM
I think we're a group who's very tolerant towards Apple stuffing this up so badly to begin with :D

The caller ID and "start conversations as" settings themselves should've been synced through iCloud.

nightelves
28th September 2012, 07:19 PM
How did you get it to merge? I'm on 10.8.2 and my phone number messages are not merge. Do you need to be on the latest iOS for it to merge because I'm on 5.0.1 atm.

savas
28th September 2012, 08:32 PM
You may need to be on iOS 6. I'm not sure because all my devices are on iOS 6 and it works fine. Try toggling iMessage on/off on all devices and see if that works, otherwise you may have to upgrade if your devices support it :)

nibbles
29th September 2012, 07:50 AM
my imesssage today was sending their reply to my laptop...but not my phone..
which was rather irritating.. i think ive fixed it..

apparently imessage on my phone was turned off...

Yeah, Mine had this trouble as well. I am certain I didn't turn it off, don't know why it decided to turn it off when adding my iMac.

Jamesvdm
30th September 2012, 11:25 AM
Does iMessage still spam notifications after the mac wakes from sleep?

savas
30th September 2012, 11:31 AM
Thankfully not. Messages are synced when Messages.app is opened, though sometimes the messages are synced out of order. The order is fixed when next opening the app though.