PDA

View Full Version : Remote controlling my Mac from a PC



snark
27th November 2005, 09:02 PM
I am looking to find a solution which will allow me to remote control my Mac (OSX 10.4.3) from a PC (Windows XP). Both are on the same LAN - behind my NAT router.

I had a quick search of this forum and found a post that recommended using TightVNC on the PC and Apple Remote Desktop. However, when I tried this, I got an error on the TightVNC viewer "incompatible version". I downloaded version 1.2.9.

Am I doing something wrong, or is it truly incompatible? I have enabled Apple Remote Desktop on the Mac, under Sytem Prefs - Sharing - Services, and specified a guest account. Is there anything else I should have done?

Is there a better way?

Thanks in advance,
P

dangelovich
27th November 2005, 09:07 PM
In the Sharing system preference, enable the option "VNC viewers may control screen with password"
Specify a password and then use that when you connect up. I use RealVNC on my PCs, and I just leave out the username...

snark
27th November 2005, 09:32 PM
Originally posted by dangelovich@Nov 27 2005, 10:07 PM
In the Sharing system preference, enable the option "VNC viewers may control screen with password"
Specify a password and then use that when you connect up. I use RealVNC on my PCs, and I just leave out the username...
Thanks for your prompt response.

Yep, have enabled that option. Still no luck. I downloaded RealVNC (just the viewer, as I presume that's all I need), and it is telling me that there are "no matching security types".
Sounds like I have missed something on the Mac. It's connected to my router over wireless using built in Airport. Could that be a problem?

snark
27th November 2005, 10:04 PM
Ok, so it's working now, after restarting the Mac. I thought it was only Windows that needed the computer to be rebooted for configuration changes to work :huh:

Oh - and I guess I don't need to enable any users in the preferences, since I appear to get the access of what ever user is logged in at the time. That must only be for the proper Apple Remote Desktop, right?

dangelovich
27th November 2005, 10:04 PM
Make sure the mac's settings match the attached image...
You'll need to have the enabled user selected in the list when you go checking the boxes on the right.


EDIT: Looks like it's working then. The Remote Desktop server probably just needed to be restarted for some reason...

snark
27th November 2005, 10:27 PM
Thanks again for your prompt reply.

I'm a little confused by your last post with the screen shot. You don't seem to have the remote VNC option ticked. But in your first post, you said to check the box "VNC viewers may control screen with password".

Anyway, I have tried various combinations, and the only way it works is to have the VNC viewer with password ticked. As I said, I've disabled all that other user stuff, because it doesn't seem to do anything.

cheers,
P

dangelovich
28th November 2005, 07:09 AM
Yeah... sorry about that. I must have accidentally unticked it when I was taking the screenshot... and it explains why I couldn't connect to the damn thing last night :D

I've updated the picture, just for the record.