PDA

View Full Version : iCloud not pushing emails ?



LevMac
22nd October 2011, 05:10 PM
Not sure if its just me, but I have everything setup correctly, yet when I get sent an email, my Mail app does not notify me of any emails until I actually open the Maill app and it manually comes through.

I have everything set to "push" and checked all my settings, if I leave the Mail app open in the background and I get sent an email it does notify me, but if its actually closed it doesn't, I think this may be a bug in the iOS

carlow1
22nd October 2011, 05:24 PM
I've had the same problem. My emails get pushed on my iPhone, but not on my iPad. The setting are exactly the same. I think it must be an iCloud thing. Hopefully it will be fixed soon.

LevMac
22nd October 2011, 05:29 PM
I've had the same problem. My emails get pushed on my iPhone, but not on my iPad. The setting are exactly the same. I think it must be an iCloud thing. Hopefully it will be fixed soon.

Yeah, well both my iPad and iPhone does not get my emails pushed, unless as I said the Mail application is actually left running and open in the background, but prior to updating to iOS 5, the Mail application used to be closed but still pushed emails through and notified when a new email was received...

Let's hope theres a fix coming

danelaban
22nd October 2011, 05:55 PM
No problem here. My @me.com email is pushed to both iPad and iPhone even if the mail app is closed from the multi-tasking bar. My @gmail.com doesn't but that's because it only checks a POP3 server periodically (too many features are missing from google sync). Are you sure you're using an email that supports push?

LevMac
22nd October 2011, 06:28 PM
No problem here. My @me.com email is pushed to both iPad and iPhone even if the mail app is closed from the multi-tasking bar. My @gmail.com doesn't but that's because it only checks a POP3 server periodically (too many features are missing from google sync). Are you sure you're using an email that supports push?

Hi mate, yeah I was using a Mobile Me account with push enabled, transferred it over to iCloud with push still switched on, and no good :(

TJA77
23rd October 2011, 06:29 PM
Having the same problems here. Has to be an iCloud thing

supafly
23rd October 2011, 06:46 PM
Yep, another one here having the same issues. I am receiving on my iPad2 but not my iPhone4.

DJY
26th October 2011, 07:58 PM
ditto for me.

My .mac account become MobileMe became iCloud.
Was push before... says it is still push now... but it doesn't.

wolfie
26th October 2011, 08:07 PM
me too. no push on my iphone4 but on ipad2 and osx mail no problem.

Kinda good to know its not just me, im assuming theres still bugs to be sorted out in icloud

NeoRicen
26th October 2011, 08:18 PM
Same here, but I had the problem for months before with MobileMe. Periodically it will seemingly arbitrarily decide to stop pushing emails. Every now and again it will work for a little bit before stopping.

mitty
26th October 2011, 08:43 PM
I'm not using icloud mail myself but we gave my partners old 3GS to my mother and she's using an icloud address and is having the issues described here. Who knows if it's an icloud issue or an iOS5 issue?

carlow1
26th October 2011, 09:18 PM
Mine started working today. It's pushing to my iPhone and iPad now. I didn't change anything. It must be an iCloud thing.

wavydave
6th November 2011, 02:55 AM
Push email with iCloud is hit or miss for me. Used to work perfectly under MobileMe. Usually I have to open the mail app and messages will start to download. Sometimes if I power off/on my iPhone push email will work for a day or so and then same issue. My iCloud is set to push and all other email accounts are fetch (15 min).