PDA

View Full Version : HDD Replaced - CD drive now won't read any CDs



froggy
22nd November 2005, 11:33 AM
Hi wise people

I've installed a replacement HD in my G3 clamshell. It wasn't too hard a job but I don't think that it is something that I'd like to do every day! :P

The computer works fine except that I now can't read any CDs. Once a CD is in the drive, I can still use the push button on the tray to eject it. I know that that isn't supposed to happen! Any ideas, please, on what I could have done wrong?

Thanks in advance for all your collective wisdom and help!

Andrew

timdotexe
22nd November 2005, 01:12 PM
Does it show up in system profiler?

froggy
22nd November 2005, 01:38 PM
Originally posted by timdotexe@Nov 22 2005, 01:12 PM
Does it show up in system profiler?
Yes

gelfie
22nd November 2005, 02:12 PM
This is perfectly normal.

See in any Mac there is a finite amount of "Workingness". Previously you had a surplus of this "Workingness" as your hard drive, being broken was not using any.

Installing a new hard disk has obviously thrown your "Workingness" balance into deficit, and therefore your CD drive doesn't work.

While this phenomenon is more often seen in the PC world, it is possible that due to the small size of your G3 Clamshell, Apple were forced to skimp on the amount of "Workingness" included. This was also seen on the White G3 iBooks, and early iPod Nanos.

Quamen
22nd November 2005, 06:43 PM
Did you check the jumper settings on both drives? It's possible that both the Hard Drive and the CD drive are set to master and thus will conflict with each other causing only one to work properly.

Other than that you could try a different cable.

froggy
22nd November 2005, 06:54 PM
Originally posted by gelfie@Nov 22 2005, 02:12 PM
This is perfectly normal.

See in any Mac there is a finite amount of "Workingness". Previously you had a surplus of this "Workingness" as your hard drive, being broken was not using any.

Installing a new hard disk has obviously thrown your "Workingness" balance into deficit, and therefore your CD drive doesn't work.

While this phenomenon is more often seen in the PC world, it is possible that due to the small size of your G3 Clamshell, Apple were forced to skimp on the amount of "Workingness" included. This was also seen on the White G3 iBooks, and early iPod Nanos.
Interesting!
:P

jeremy_warnock
22nd November 2005, 07:09 PM
cheack cable and jumpers as mentioned, the fact the you can eject with the push button indictes your getting power to the drive so check the data cable, also try to boot from your mac install disk, - if you can then the cd is working fine and the problem lies else where perhaps disk utility will help solve the issue - if you cannot boot from your cd, them there is a problem with datacable or jumper

froggy
22nd November 2005, 07:43 PM
Its getting worse now :(

Sometimes it is reading, but at other times it isn't. Same CD sometimes won't read but at other times it will.

Sound like dodgy cable?


Cheers,
Andrew

Quamen
22nd November 2005, 08:14 PM
Sounds like a dodgy cable or jumper settings conflicting between the two devices on the cable.

Check both of them.

froggy
22nd November 2005, 08:39 PM
I've never before had to check jumper settings on a Mac! Is this normal?

Come to think of it, I don't think that I know what they should be or how to check things like that. Hmmmmm

Rayd
22nd November 2005, 10:07 PM
wouldnt the replacment HD defaulty set to Slave? and wouldnt the CD drive be set to slave also? ... is that the problem? also you might want to check if the data cable has been moved.

also, wrong forum :)

kim jong il
22nd November 2005, 10:12 PM
It uses an ATA/IDE bus (each bus supports two devices; master and slave as with you clamshell) but may not support Cable Select (CS) where the black plug is 'Master' and the grey plug 'slave'. Your CD should be set to master and the hard drive to slave in a standard non cable select configuration. You will find jumper settings on the physical drive (be careful sometimes they use a mirror image diagram)

kim